ADSL2+ Modem is a Other Networking Devices product. Key specs — Origin: China (Mainland).
Product Description
Model No.:DL820
Product Origin:China
Brand Name:Evik
Price Terms:EXW
Payment Terms:T/T
Certification:CE, FCC, RoHS
Description:Specifications: 1) Conexant 8120 (Globelspan) chipsets as Main IC 2) Full-rate ADSL and G. Lite operation 3) ANSI T1. 413 Issue 2 4) ITU G.992.2 (G. Lite) 5) ITU G.992.1 (G. dmt) 6) Rate-adaptive 7) Up to 24Mbps downstream data rate8) Up to 1Mbps upstream data rate 9) Full-rate and suitable with ADSL router and support bridge 10) Support various devices DSLAM 11) The most effective distance: 7.5km12) Plug-and-play compatible 13) Telephone and surfing can be simultaneous due to external audio splitter 14) Support system upgraded via local PC 15) Attractive and convenient WEB configurable interface, suitable with existing Server/browser mode and no need any software installed16) LED connection status indicator17) IAV function18) Super compatibility of various ADSL standards, ATM and PPP protocols, including RFC 1483 bridge/ RFC 1483 router; classical IP over ATM (RFC 1577); PPP over ATM (RFC 2364); PPP over Ethernet (RFC 2516)
Related Products
ENP7020C 200W FLEX PC POWER SUPPLIES REPLACE AM630BS20S
1U Flex ATX PC Power Supply
firewall case with 6 lans
2u Rackmount Network Security Platform IEC-528F
2u Network Security platform IEC-522
2U Rackmount network Security Firewall Platform IEC-526
Network security platform with D525 Dual Core CPU
1U Rackmount Nework Security Appliance IEC-516